New hosting provider

Site news and updates.
Post Reply
User avatar
adum
Site Admin
Posts: 397
Joined: Tue Sep 30, 2008 5:09 pm

New hosting provider

Post by adum »

it was a lot of effort, but hopefully worth it.

many users have noticed how slow this site has been recently. i certainly have. it has been hosted on a provider for Dreamhost for a long, long time now. but their service has been suffering. finally, it was time to move on. i chose Amazon.

old setup: Dreamhost private virtual server with Apache/PHP 5.2/FastCGI, Dreamhost private virtual Mysql server

new setup: Amazon EC2 instance running nginx/PHP-FPM 5.5/FastCGI, RDS Mysql

preliminary results: 20x speedup. that's not a typo. home page generation went from 1.6 seconds down to 60ms. let's see how it holds up, but i'm optimistic.

some of the RSS feeds are broken. probably other stuff i haven't figured out yet. please let me know what you find.
User avatar
adum
Site Admin
Posts: 397
Joined: Tue Sep 30, 2008 5:09 pm

Re: New hosting provider

Post by adum »

here's a graph of loading the home page after switching to the new server.
Attachments
Screen Shot 2014-08-29 at 10.27.36 AM.png
Screen Shot 2014-08-29 at 10.27.36 AM.png (64.29 KiB) Viewed 406714 times
helloqtion
Posts: 2
Joined: Sun Aug 31, 2014 1:03 am

Re: New hosting provider

Post by helloqtion »

Hello,

I suppose you already noticed it, but we can't access josekipedia anymore (we got the goproblems page) and I also saw some php error, but they did not appears anymore.

I'm happy to know the access will suffer less lags :)

Edit : when I posted that message I got some errors you will see in the postmessage.png attached file.
Attachments
Errors while posting message
Errors while posting message
postmessage.png (56.46 KiB) Viewed 406577 times
emptytriangle
Posts: 1
Joined: Sun Aug 31, 2014 8:59 am

Can anyone tell me how to access Josekipedia?

Post by emptytriangle »

When I try josekipedia.com I get go problems.com instead. It is a nice site, but not when I want joseki help. What is going on???
User avatar
adum
Site Admin
Posts: 397
Joined: Tue Sep 30, 2008 5:09 pm

Re: New hosting provider

Post by adum »

should be working now, thanks
helloqtion
Posts: 2
Joined: Sun Aug 31, 2014 1:03 am

Re: New hosting provider

Post by helloqtion »

It works fine. Thanks !
JocaRamiro
Posts: 3
Joined: Sat May 22, 2021 10:05 am

Re: New hosting provider

Post by JocaRamiro »

Hello Admin,

For the last few days, when I try to look at a problem, the screen is blank. Could this be caused by your site move?
User avatar
BartTM
Posts: 119
Joined: Mon Sep 21, 2009 1:46 pm

Re: New hosting provider

Post by BartTM »

Nothing changed (apparently) and all works well as far as I can see.
Maybe try another browser, or check whether you disabled JavaScript in your browser, or maybe you use a browser add-on that's blocking essential parts of the page.
JocaRamiro
Posts: 3
Joined: Sat May 22, 2021 10:05 am

Re: New hosting provider

Post by JocaRamiro »

Hello Bart, and thank you.

I suspect the problem was that my browser (Microsoft Edge) suddenly decided not to like Javascript. However, I tried the alternative of Chrome. All is fine.
Post Reply