Cannot see problems anymore

Cannot see problems anymore

Postby BartTM on Thu Mar 24, 2011 3:47 am

Hi,

I can no longer see problems on the site; the board does not appear. Java (1.6.0.24) keeps loading for minutes and finally just shows a grey window.
Judging the problem attempt ratings of the last 2 problems (0/0) I'm not the only one with this problem..?
Finally, looking at my own problem page fills the screen with SQL errors.
Something is amiss...?
User avatar
BartTM
 
Posts: 81
Joined: Mon Sep 21, 2009 1:46 pm

Re: Cannot see problems anymore

Postby jaguarondi on Thu Mar 24, 2011 4:28 am

I have got the same problem (java 1.6.0_07-b06).

If you do a search on a set of problem, you have the following warning :
"Warning: mysql_numrows(): supplied argument is not a valid MySQL result resource in /home/adumps/web/go/html/prob.php3 on line 106 invalid problem set "

When I look at the page source, I see the following text :
"Table './go/comment' is marked as crashed and last (automatic?) repair failed, qry: SELECT count(*) FROM comment WHERE problem = '14643' AND alive = 1"
jaguarondi
 
Posts: 5
Joined: Wed Jul 28, 2010 4:01 am

Re: Cannot see problems anymore

Postby BartTM on Thu Mar 24, 2011 4:46 am

Apparently the ./go/comment table is used in many places as almost everywhere I get messages like:
Table './go/comment' is marked as crashed and last (automatic?) repair failed, qry: SELECT COUNT(*) FROM `comment` WHERE authorid = 3759

Btw. it no longer takes minutes for Java to present a grey rectangle, it now happens almost immediately. At least some kind of progress ;)
User avatar
BartTM
 
Posts: 81
Joined: Mon Sep 21, 2009 1:46 pm

Re: Cannot see problems anymore

Postby psblue on Thu Mar 24, 2011 5:19 am

I have the same problem:

Table './go/comment' is marked as crashed and last (automatic?) repair failed, qry: SELECT COUNT(*) FROM `comment` WHERE authorid = 47505 when I login, then the gray screen where problems should appear; it happened yesterday evening while editing my first problem (screen just crashed). so the last problem is not yet finished. yet, someone achieved to open it cause I have a first - very bad, 1 star :( - rating.
psblue
 
Posts: 2
Joined: Wed Mar 09, 2011 1:51 am

Re: Cannot see problems anymore

Postby xavlours on Thu Mar 24, 2011 8:14 am

I can't reproduce the sql error since I have no problems, but I can confirm the gray board problem.
I managed to get an error message from the applet (on iced tea 1.6.0_20 but I don't think it matters) :
createGUI didn't successfully complete
Exception in thread "Thread-12" java.lang.NullPointerException
at com.adum.go.Goban.goSmall(Unknown Source)
at com.adum.go.GoApplet.autoSizeGoban(Unknown Source)
at com.adum.go.GoApplet.run(Unknown Source)
at java.lang.Thread.run(Thread.java:636)

If I can be any more help ...
xavlours
 
Posts: 1
Joined: Mon Oct 04, 2010 7:57 pm

Re: Cannot see problems anymore

Postby Beagles on Thu Mar 24, 2011 9:02 am

When I select a problem all the text content shows but none of the go board etc is displayed. Looks like none of the Java content is displayed.
Beagles
 
Posts: 1
Joined: Mon Mar 21, 2011 6:26 pm

Re: Cannot see problems anymore

Postby BartTM on Thu Mar 24, 2011 12:11 pm

Apparently the problem has been fixed now as I can see the (go) problems again.
User avatar
BartTM
 
Posts: 81
Joined: Mon Sep 21, 2009 1:46 pm

Re: Cannot see problems anymore

Postby kiga on Thu Mar 24, 2011 4:41 pm

I, too, get an error message:
Warning: mysql_numrows(): supplied argument is not a valid MySQL result resource in /home/adumps/web/go/html/prob.php3 on line 106
invalid problem set

This happens NOT on the main http://www.goproblems.com/prob.php3 page where it selects a problem at random.
This occurs when I click on the "Problems" item (to go to http://www.goproblems.com/problems.php3 ) and select a search of some kind. I perform a search (of any kind it seems) and it gives me a list of problems that meet that criterion. But when I select one, I get the above message, and the go board does not appear.

I am using a MacBook Pro, running Mac OS 10.6.6, running Camino 2.0.7 (I get the same behavior on Safari 5.0.4, except that I do get a go board with the problem on it, and the error message.)
kiga
 
Posts: 2
Joined: Sat Oct 23, 2010 6:48 pm


Return to Bugs

Who is online

Users browsing this forum: No registered users and 4 guests

cron