Problem floating in middle of board

Problem floating in middle of board

Postby ccsco on Wed Jul 01, 2009 6:28 am

I have a problem in my sandbox (12868). I can't get the stones to line up along the edge; it appears floating a few lines up on the board, even though in the graphical editor I've clearly put the stones on the edge. I'm using a 13x13 board, but I don't see why that should change things...
:(
Any help?
ccsco
 
Posts: 1
Joined: Sat Apr 04, 2009 2:30 pm

Re: Problem floating in middle of board

Postby adeus666 on Mon Aug 09, 2010 7:06 pm

I seem to have had the same problem. I don't have a solution yet.

I spent over 2 hours making my first problem to contribute with detailed comments and paths, and when it went active it was instantly invalid. When making it I put it into the lower left corner of a 9x9 board and when it went live it was placed in the top left 9x9 of a 19x19 board with 10 lines of free space added underneath (removing it from the corner so that nothing makes any sense about it). In the 10mins or less that it took me to figure out how to deactivate it, I already had 3 users try it out and got a bad review. Is it possible I activated a bug in the problem builder? I went back in to edit and resize the board to 9x9 multiple times and it keeps changing back to 19x19 when I go to test it.
Someone please help us?
Is there any easy way to correct this without redoing all the work on a 19x19?
adeus666
 
Posts: 1
Joined: Fri Aug 28, 2009 9:46 am

Re: Problem floating in middle of board

Postby tails on Mon Aug 09, 2010 10:46 pm

Hi,

It seems the applet has a bug that it won't store the board size into SGF.
Unfortunately I don't have time to fix the bug soon, but I've fixed your problem (id=13897) by editing the SGF by hand.

Incidentally: The applet seems to have another bug. When reading SGF, all appearance of "WRONG" in node comments are recognized and treated specially just like "RIGHT", but they are ignored when writing SGF. As a result, all "WRONG" get eliminated if we edit a problem with the applet. I must fix that too.
tails
 
Posts: 90
Joined: Thu Oct 23, 2008 12:10 pm

Re: Problem floating in middle of board

Postby tails on Wed Sep 01, 2010 7:18 am

I have just fixed the bug. Now we should be able to create 9x9 problems properly.
Please let me know if anything is still wrong.
tails
 
Posts: 90
Joined: Thu Oct 23, 2008 12:10 pm


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron