New site version

Site news and updates.

Postby admin on Mon Apr 24, 2006 4:36 pm

today the site moved to the new version which had been on test.goproblems.com for a while. please discuss here any problems you have. i realize that not everyone tried the test site, so this may be the only way to see just how controversial the change really is. if things are too messed up, i can offer the old version as an option.

adum

{Posted by admin}
admin
 

Postby dmg on Tue Apr 25, 2006 1:38 am

And the RSS Feed doesn't work anymore...

{Posted by dmg}
dmg
 

Buuuug

Postby MeadowFire on Tue Apr 25, 2006 11:48 am

I've found a really odd bug with this new rendering of goproblems. It seems that, once the applet is loaded and drawing to the page, if I use the scroller on the mouse to get the page down so I can see the problem (like I used to with the old version) the browser simply crashes completely and this is consistent. This is very odd indeed. The applet doesn't seem to like being moved at all in fact, even in the normal way (leaving echoes down the page). I remember on the old one where the timer appeared at the top left of the screen?! Must be something very wrong with the drawing that's causing these things. See if you can work it out. A possible solution to this problem would be to make the whole thing smaller so that it actually fits on the screen... But the scrollbar problem is the worst. Another problem I have is when I open two instances of the applet at once (for example to look at the attempt paths). After closing one of them the other browser window ceases to function correctly (not opening new pages etc.) Not all the time, but very frequently anyway. I don't know how many can reproduce these problems on their computers, but please try!

Edit: In fact, maybe you should review and extensively test the whole thing. Try a range of browsers and operating systems to make sure, and try to make it run efficiently and quickly with as little memory/CPU usage as possible! Make sure every line of code is scrutinised and all bugs found! You might like to put the old system back up so I can use it ;) And by the way, when I used test.goproblems.com everything seemed to work fine... What did you change???

{Posted by MeadowFire}
MeadowFire
 

Postby admin on Tue Apr 25, 2006 12:37 pm

thanks for the bug report. actually, everything is exactly the same for this version as from test.goproblems.com, so it's odd you're having problems here.

things like screen drawing issues, browser crashing etc are due to bugs in Java and the browser and the OS, and are out of my control, unfortunately.

i'm probably going to put the old version back up for those who want it.

adum

{Posted by admin}
admin
 

Postby admin on Tue Apr 25, 2006 2:15 pm

RSS should be fixed, thanks.

adum

{Posted by admin}
admin
 

new test site

Postby phid lawless on Tue Apr 25, 2006 2:45 pm

I have been enjoying your site for some time now.

I currently cannot receive your go problems (on the new site version) on IE.

It does work on Safari.

I am using a new G5, if that is important.

Cheers.

Phid

{Posted by phid lawless}
phid lawless
 

Sleipnir

Postby yuheysze on Wed Apr 26, 2006 3:00 am

I use an IE based browser named Speipnir and I can't load the new graphics with it. It works on IE though. I wonder if there is a solution to this.

{Posted by yuheysze}
yuheysze
 

the old version does not work as in the past

Postby grosspomm on Sat Apr 29, 2006 12:22 pm

On my computer the new version doesn't work, maybe because my computer is a little bit old, and almost dead... So i use the old version, but, it seems that when i solve, or not, a problem it doesn't remember it. Problems tryed with the old version, seems to be , if i tryed later to be as if I nether prove it.
I will be nice to fix this problem!

Thank you
yannick

{Posted by grosspomm}
grosspomm
 

Postby iopq on Mon May 01, 2006 1:19 pm

I know a problem...

in Firefox the new version focuses on the show solution so the mouse scroll scrolls through the options for Numbered Solution and Navigate solution, which sucks

{Posted by iopq}
iopq
 

cannot see graphics

Postby maury ostroff on Mon May 01, 2006 2:32 pm

I was using the site fine, until the latest release last week. I can no longer see the graphics of the problem itself. I'm running IE version 6.0.2900...

Then I tried using Firefox and again the graphics wouldn't display either

{Posted by maury ostroff}
maury ostroff
 

Next

Return to News

Who is online

Users browsing this forum: No registered users and 3 guests

cron